SQL 2008 error The version of SQL Server instance MSSQLSERVER does not match the version expected by the SQL Server update. The installed SQL Server p

If you get the error:

The version of SQL Server instance MSSQLSERVER does not match the version expected by the SQL Server update. The installed SQL Server product version is 10.0.1600.22, and the expected SQL Server version is 10.1.2531.0.
Run the SP and then the CU.