TF80068 Team Foundation error when opening Project Server file from Project 2010

Odds are you will see this error if you have worked with Project Server and Team Foundation Server. In my case I encountered this whilst dealing with a puzzling problem with Project 2010. Specifically it kept hanging when I tried to open a remote project from a 2010 Project Server. Here is how I tried to fix it in case you too encounter the following error “TF80068 Team Foundation encountered an error while communicating with the server. Check your connection and try again

TF80068 Team Foundation encountered an error while communicating with the server

Looking at the error I thought, incorrectly that the fix was going to be relatively simple. Recently I had integrated a TFS Team Foundation Server 2010 into a domain with Project Server 2010 and SharePoint 2010. All went without any problems and actually was a relatively painless experience as installations and configurations go. So mistake #1 was assuming this was the problem. I’m detailing it out here as knowing how to do ‘it’ can be helpful but again take note. This is not the solution.

How to disable the TFS Add-In in Microsoft Project 2010

Open Project and right click anywhere that is not a button or link on the ribbon. Select the “Customize the Ribbon” option from the context menu that appears.

In the new window “Project options” click on the “Add-Ins” menu option on the left side.

Add-Ins

At the bottom click on “Go” with “COM Add-Ins” selected from the drop down menu.

In the new window remove the check “Team Foundation Add-In“. Click on OK and close and reopen Project.

Team Foundation Add-In

As already mentioned this did not resolve the issue.

So I turned to Google and found this http://support.microsoft.com/kb/2540158 … A hotfix for those with Visual Studio 2010 and SP1. Great! Problem solved! Or so I thought. One needed to email Microsoft to get it. So I tried something else.

Inside the folder “C:Program Files (x86)Microsoft OfficeOffice14” I created a file called “winproj.exe.config” and put the following inside it (note that there are spaces immediately to the right of the “<” characters so that they will render correctly in the browser):

< ?xml version=”1.0″?>
< configuration>
< system.diagnostics>
    < switches>
     < add name=”General” value=”4″ />
    
    < trace autoflush=”false” indentsize=”4″ />

Upon opening Project I expected to see a logfile with lots of good information inside of it here: “C:Users[username]AppDataLocalTemp”. And I did. Too many in fact.