How to change Xbox streaming on Windows 10 to “very high quality”

There’s a “very high quality” option that can be unlocked by tinkering with some of the Xbox app’s configuration files.

To enable:

  1. Edit userconsoledata in the xbox app folder C:\Users\%USERNAME%\AppData\Local\Packages\Microsoft.XboxApp_~~~~~~\LocalState
  2. Change IsInternalPreview to true.

As others have noted it can overwhelm your network if you’re due for an upgrade…

https://www.reddit.com/r/xboxone/comments/3gq0pk/very_high_settings_in_xbox_streaming/

http://arstechnica.com/gaming/2015/08/xbox-streaming-on-windows-10-has-a-hidden-very-high-quality-setting/

 

How to MANUALLY install Redmine 3.x on Windows Server 2008 R2

redmine_logo_v1  Redmine is a free and open source, web-based project management and issue tracking tool. It allows users to manage multiple projects and associated subprojects. It features per project wikis and forums, time tracking, and flexible role based access control. It includes a calendar and Gantt charts to aid visual representation of projects and their deadlines. Redmine integrates with various version control systems and includes a repository browser and diff viewer. The design of Redmine is significantly influenced by Trac, a software package with some similar features. Redmine is written using the Ruby on Rails framework. It is cross-platform and cross-database and supports at least 34 languages.

There are issues with installing Redmine on Windows due to some gems. The key to a successful outcome is to match the versions. Obviously with time this situation will change…

This ‘should’ take < 30 minutes.

You can always use the Web Platform Installer process. Google/Bing/etc. will help you find it.

You WILL experience a Json gem error around step 4.3 – just keep following the directions.

IGNORE “DL is deprecated, please use Fiddle”

Assumptions

  • You have IIS up and running
  • You already have an instance in place of SQL, MAriaDB, POST/My etc
  • Rmagick is NOT being/already installed.

Download the following:

  • Ruby 2.0.0 x32 – http://rubyinstaller.org/downloads/
  • Ruby Dev Kit for use with 2.0 x32 – http://rubyinstaller.org/downloads/
  • Redmine 3.0.4 – http://www.redmine.org/projects/redmine/wiki/Download

‘THE’ Process

  1. Install Ruby. Just double click, agree, and accept the defaults.
  2. Create the IIS site that will host Redmine.
  3. Extract the Redmine file into the above IIS site folder. Let us assume it shall be C:\inetpub\wwwroot\redmine\
  4. Open a Ruby Command prompt as Administrator. Capture1
    1. CD into the folder C:\inetpub\wwwroot\redmine\ and run
    2. gem install bundler
    3. bundle install –without development test rmagick
  5. Install the Dev Kit
    1. Double click and extract to a folder that makes sense. E.g. C:\RubyDevKit
    2. CD into that folder and run:
      • ruby dk.rb init
      • ruby dk.rb install
      • gem install json -v ‘1.8.3’
  6. Go back to C:\inetpub\wwwroot\redmine\ and run
    • bundle install –without development test rmagick
    • bundle exec rake generate_secret_token
    • rake db:migrate – IF you get a SQL error here you probably have the wrong PW in your C:\inetpub\wwwroot\redmine\config\database.yml file OR your user is different.
    • set RAILS_ENV=production
    • set REDMINE_LANG=en
    • bundle exec rake redmine:load_default_data
  7. In theory you should now have a functional instance of Redmine BUT you are not yet done. Run the following to test
    • bundle exec rails server webrick -e production
    • OPEN a browser on the server and check http://localhost:3000
    • If you see what looks like Redmine CTRL+C and continue.
    • NOTE: You CAN run Redmine like this but it is not really stable enough for ‘real’ production use.
  8. IIS needs to be set up to run Ruby & Redmine. This detail will be added at a later date when I have time.

 

This seems useful / complimentary: http://jonathanmatthey.com/project/opensource/2012/11/01/redmine-sprint-reports.html

TF80068 Team Foundation error when opening Project Server file from Project 2010

Odds are you will see this error if you have worked with Project Server and Team Foundation Server. In my case I encountered this whilst dealing with a puzzling problem with Project 2010. Specifically it kept hanging when I tried to open a remote project from a 2010 Project Server. Here is how I tried to fix it in case you too encounter the following error “TF80068 Team Foundation encountered an error while communicating with the server. Check your connection and try again

TF80068 Team Foundation encountered an error while communicating with the server

Looking at the error I thought, incorrectly that the fix was going to be relatively simple. Recently I had integrated a TFS Team Foundation Server 2010 into a domain with Project Server 2010 and SharePoint 2010. All went without any problems and actually was a relatively painless experience as installations and configurations go. So mistake #1 was assuming this was the problem. I’m detailing it out here as knowing how to do ‘it’ can be helpful but again take note. This is not the solution.

How to disable the TFS Add-In in Microsoft Project 2010

Open Project and right click anywhere that is not a button or link on the ribbon. Select the “Customize the Ribbon” option from the context menu that appears.

In the new window “Project options” click on the “Add-Ins” menu option on the left side.

Add-Ins

At the bottom click on “Go” with “COM Add-Ins” selected from the drop down menu.

In the new window remove the check “Team Foundation Add-In“. Click on OK and close and reopen Project.

Team Foundation Add-In

As already mentioned this did not resolve the issue.

So I turned to Google and found this http://support.microsoft.com/kb/2540158 … A hotfix for those with Visual Studio 2010 and SP1. Great! Problem solved! Or so I thought. One needed to email Microsoft to get it. So I tried something else.

Inside the folder “C:Program Files (x86)Microsoft OfficeOffice14” I created a file called “winproj.exe.config” and put the following inside it (note that there are spaces immediately to the right of the “<” characters so that they will render correctly in the browser):

< ?xml version=”1.0″?>
< configuration>
< system.diagnostics>
    < switches>
     < add name=”General” value=”4″ />
    
    < trace autoflush=”false” indentsize=”4″ />

Upon opening Project I expected to see a logfile with lots of good information inside of it here: “C:Users[username]AppDataLocalTemp”. And I did. Too many in fact.

Completely removing the User Profile Service Application will prevent you from taking other benefits of the Service.

If you do not want the My Site option to be given to users, you will have to go into Central Administration > Application Management > Manage service applications > User profile service application > Manage User Permissions (ribbon) and set appropriate permissions.

refer: http://howtosharepoint.blogspot.com/2010/11/hide-disable-my-site-my-profile-and.html

MongoDB: Looking at the file system

MongoDB stores objects in a binary format called BSON. BinData is a BSON data type for a binary byte array. However, MongoDB objects are typically limited to 4MB in size. To deal with this, files are “chunked” into multiple objects that are less than 4MB each. This has the added advantage of letting us efficiently retrieve a specific range of the given file.

While we could write our own chunking code, a standard format for this chunking is predefined, call GridFS. GridFS support is included in many MongoDB drivers and also in the mongofiles command line utility.

http://blog.mongodb.org/post/183689081/storing-large-objects-and-files-in-mongodb

GridFS is a storage specification for large objects in MongoDB. It works by splitting large object into small chunks, usually 256k in size. Each chunk is stored as a separate document in a chunks collection. Metadata about the file, including the filename, content type, and any optional information needed by the developer, is stored as a document in a files collection.

So for any given file stored using GridFS, there will exist one document in files collection and one or more documents in the chunks collection.

http://www.mongodb.org/display/DOCS/GridFS+Specification

  1.   
  2. $m = new Mongo(); //connect  
  3. $db = $m->selectDB(“example”); //select Mongo Database  
  4.   
  5. $grid = $db->getGridFS(); //use GridFS class for handling files  
  6.   
  7. $name = $_FILES[‘Filedata’][‘name’]; //Optional – capture the name of the uploaded file  
  8. $id = $grid->storeUpload(‘Filedata’,$name//load file into MongoDB  
  9.   
  10. ?>  

www.lightcubesolutions.com/blog/?p=209

http://en.wikipedia.org/wiki/MongoDB

Replacing ZFS on OS X… What now?

It’s clear that Apple and Sun just could not agree on licensing so the ZFS party has come to an end on OS X. A shame but also an exciting opportunity for something new. It’s pretty obvious that Apple will now build its own advanced filesystem instead of adopting ZFS or its Linux cousin BtrFS (itself an Oracle project, which comes with licensing that is also highly likely to be incompatible with Apple’s xnu kernel…) Why is it clear / obvious?

  • With the release of Snow Leopard the base of the os is stable, fast, and the resources that did all the work are now “free” to work on something new.
  • The mathematical problems that ZFS addressed when originally conceived have been the focus of the general community for some time now. Translated = there are more, and refined, options now.

So time will tell what will happen next unless they can sort it all out…

http://mail.opensolaris.org/pipermail/zfs-discuss/2009-October/033125.html
> Apple can currently just take the ZFS CDDL code and incorporate it   > (like they did with DTrace), but it may be that they wanted a "private   > license" from Sun (with appropriate technical support and   > indemnification), and the two entities couldn't come to mutually   > agreeable terms.  I cannot disclose details, but that is the essence of it.  Jeff